• Reklama

Meizu m2 Mini problem z kompasem/magnetometrem

Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » niedziela, 27 grudnia 2015, 15:18

Witam
Krótko mówiąc nie działa kompas w żadnej aplikacji typu kompas ani w żadnej mapie. Próbowałem kalibracji w różnych apk "kompas" zero efektu. Każda aplikacja tego typu pokazuje poziom natężenia pola na poziomie 450-500μT (a z tego co wiem powino być ok 50μT )
Zaraz po ponownym uruchomieniu telefonu wskazuje ok 330.
Jak to wyglada w waszych telefonach? Jakieś pomysły?

I teraz zastanawiam się czy to
będzie fizycznie uszkodzony czujnik, czy też możliwe ze powoduje to zamrożone i usunięcie co niektórych chińskich aplikacji?
Soft na telefonie to 4.5.3.2A +spolszczenie z forum. Telefon z Chin.
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Reklama

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez clorox » niedziela, 27 grudnia 2015, 19:00

U mnie w aplikacji Sensor test, wygląda tak:


Obrazek

Kompas nawet działa jako tako.
Avatar użytkownika
clorox
AKTYWNY
 
Posty: 713
Dołączył(a): poniedziałek, 22 czerwca 2015, 18:44
Pochwały: 36

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » niedziela, 27 grudnia 2015, 22:55

u mnie to wygląda tak: (tekst bo problemy z dodaniem załącznika a i tak będzie wiadomo o co chodzi)
x: -89,88
y: 205,50
z: -414,46
pozostałe wartości takie same.
Sprawdziłem na jeszcze jednym telefonie i na tablecie, wygląda to jak u ciebie clorox. ( i tam działają kompasy)
Coś czuję ze to będzie jednak uwalone sprzętowo. Chyba że jest możliwość ze system powoduje błędny odczyt parametrów z czujnika na każdej aplikacji?
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez clorox » niedziela, 27 grudnia 2015, 23:29

Spróbuj wejść jeszcze w engineer mode (*#*#3646633#*#*) i zrobić kalibrację sensorów.
Avatar użytkownika
clorox
AKTYWNY
 
Posty: 713
Dołączył(a): poniedziałek, 22 czerwca 2015, 18:44
Pochwały: 36

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » poniedziałek, 28 grudnia 2015, 01:15

w engineer mode> Hardware Testing> sensor
można tylko skalibrować G sensor, gyroscope, light/proximity
Msensor (obstawiam że to magnetometr) jest tylko odczyt aktualny:

Msensor data: 525 i po kropce wartości przeróżne
M sensor Accuracy : 0.0
Msensor data is not good!
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez junakk » poniedziałek, 28 grudnia 2015, 17:01

Mam dokładnie ten sam odczyt na hardware teście co kolega powyżej. Wartości rzędu 519 i komunikat, że MSensor data is not good. Kalibrację gyro robiłem przed momentem poprzez ustawienia telefonu. Jak wejdę w jakąkolwiek aplikację kompasową północ obraca mi się razem z telefonem... :shock: Czyżby to wada egzemplarza/serii? Z tego co czytam niektórym osobom na tym forum działa. Wersja romu nie mam nic do rzeczy. Sprawdzane na 4.5.4 A i 4.5.3 I. Telefon z Chin.
junakk
 
Posty: 5
Dołączył(a): poniedziałek, 28 grudnia 2015, 16:38

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez clorox » poniedziałek, 28 grudnia 2015, 18:10

No to niestety chyba wygląda na zwalony sensor :-(

U mnie wygląda to tak:
Obrazek
Avatar użytkownika
clorox
AKTYWNY
 
Posty: 713
Dołączył(a): poniedziałek, 22 czerwca 2015, 18:44
Pochwały: 36

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » poniedziałek, 28 grudnia 2015, 20:29

zauważyłem jeszcze jedną rzecz, sensor "jako tako działa", po przyłożeniu/ przesunięciu jakiegoś metalowego elementu obok sensora(sensor jest w prawym górnym rogu) wartości zmieniają się, wartości schodzą do zera, ale minimalne poruszenie przedmiotu i szaleją.
Wyłączenie na chwile telefonu powoduje spadnięcie wartości o ok połowę ale też na chwilę.
@junakk chyba trzeba zaopatrzyć się w zwykły kompas:P
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez anemusek » piątek, 1 stycznia 2016, 20:45

Czempi napisał(a):zauważyłem jeszcze jedną rzecz, sensor "jako tako działa", po przyłożeniu/ przesunięciu jakiegoś metalowego elementu obok sensora(sensor jest w prawym górnym rogu) wartości zmieniają się, wartości schodzą do zera, ale minimalne poruszenie przedmiotu i szaleją.
Wyłączenie na chwile telefonu powoduje spadnięcie wartości o ok połowę ale też na chwilę.
@junakk chyba trzeba zaopatrzyć się w zwykły kompas:P

No nie bardzo bo magnetometr i akcelerometr służą do emulowania reszty czujników.

Wysłane z mojego m2 przy użyciu Tapatalka
anemusek
 
Posty: 92
Dołączył(a): sobota, 26 grudnia 2015, 00:37
Pochwały: 1

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » piątek, 1 stycznia 2016, 23:04

anemusek napisał(a):No nie bardzo bo magnetometr i akcelerometr służą do emulowania reszty czujników.

Wysłane z mojego m2 przy użyciu Tapatalka

Domyślam się tego.. Na szczęście na chwilę obecną nie zauważyłem problemów z innymi funkcjami telefonu zwiazanymi z czujnikami. Choc sodziewam się że jeszce odczuje w przyszłości w naj mniej oczwkiwanym momencie problem z magnetomerem.
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez junakk » sobota, 9 stycznia 2016, 09:59

Mnie raz kompas w telefonie wyprowadził z lasu :-D
Pytanie: czy ktoś posługiwał się nawigacją w telefonie z wadliwym magnetometrem? Jak to wygląda? Czytałem że google maps odwala niezłe imby w widoku 3D bo nie wie w którą stronę zwrócony jest samochód :-( Jeżeli uszkodzenie kompasu rzutuje na sposób nawigowania to dla mnie tel. jest bezużyteczny...
Najlepiej jakby dało się ten czujnik wyłączyć do czasu naprawienia usterki softem (o ile to możliwe). Są przecież telefony z nawigacją bez kompasu, lepiej jakby go nie było niż wprowadzał navi cały czas w błąd...
junakk
 
Posty: 5
Dołączył(a): poniedziałek, 28 grudnia 2015, 16:38

Re: Meizu m2 Mini problem z kompasem/magnetometrem

Postprzez Czempi » sobota, 9 stycznia 2016, 10:40

O dziwo nawigacja google, działa elegancko. I pokazywała w która stronę jest ustawione auto. Tylko widok 2d. Nawigację opierają sie raczej na sygnale GPS.
Czempi
 
Posty: 14
Dołączył(a): czwartek, 19 listopada 2015, 01:41

Następna strona

Powrót do Pomoc techniczna



Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości

  • Reklama